Shoppers may be experiencing processing issues.
Incident Report for Shipt
Resolved
This incident has been resolved.
Posted Oct 15, 2020 - 20:36 CDT
Investigating
We are aware of the processing issue that shoppers may be experiencing. We are working to identify and resolve the problem as soon as possible.
Posted Oct 15, 2020 - 14:16 CDT
This incident affected: Shipt Shopper App.