Investigating reported issues with the MotherShipt
Incident Report for Shipt
Resolved
This incident has been resolved.
Posted Aug 11, 2020 - 22:14 CDT
Investigating
We're aware of the issues with the Shipt card and we're working to get this resolved ASAP! Please stay tuned for more updates.
Posted Aug 11, 2020 - 20:54 CDT
This incident affected: Shipt Shopper App.