Customer Service Voice Outage
Incident Report for Shipt
Resolved
Voice Communications should be back up and operational for our Customer Experience Team.
Posted Aug 27, 2020 - 11:49 CDT
Investigating
Currently voice communications are down for communicating with our customer experience team. If you are needing assistance, please reach out to our customer service team via: Chat or Email.
Posted Aug 27, 2020 - 11:38 CDT
This incident affected: Shipt Shopper App, Shipt Member App, and Shipt Website.