Degraded Performance
Incident Report for Shipt
Resolved
The incident with Pex has been resolved.
Posted Jan 13, 2020 - 22:27 CST
Investigating
Pex, one of our major payment processors for Shoppers, is experiencing issues. Until the Pex status is restored, many shoppers will experience difficulty checking out from stores.
Posted Jan 13, 2020 - 16:20 CST
This incident affected: Shipt Shopper App.