Shopper App Delivery History Issue
Incident Report for Shipt
Resolved
This incident has been resolved.
Posted Sep 11, 2020 - 00:38 CDT
Monitoring
We have identified the issue with the Shopper App Delivery History page not loading and are continuing to monitor it. We appreciate your patience and understanding!
Posted Sep 10, 2020 - 20:23 CDT
Investigating
Attention shoppers! We're aware of an issue with your Delivery History page and we're working to find a solution as soon as possible!
Posted Sep 10, 2020 - 18:27 CDT
This incident affected: Shipt Shopper App.