Support Team Call and Chat Availability
Incident Report for Shipt
Resolved
We can confirm this issue is now resolved.
Posted Jun 13, 2023 - 16:23 CDT
Identified
This issue has been identified. We appreciate your patience while we work to resolve it.
Posted Jun 13, 2023 - 16:09 CDT
Update
Please consider emailing support@shipt.com for any immediate needs.
Posted Jun 13, 2023 - 15:10 CDT
Investigating
We are aware of an incident impacting communication with our support teams and are currently investigating.
Posted Jun 13, 2023 - 14:47 CDT
This incident affected: Shipt Shopper App, Shipt Member App, and Shipt Website.