Update On Contacting Support
Incident Report for Shipt
Resolved
We have restored the ability to call Shipt support. Please feel free to call us again. We appreciate your patience while we worked through this issue.
Posted Sep 13, 2022 - 09:55 CDT
Investigating
We understand that an issue is currently impacting the ability for people to call Shipt support. In the meantime, we ask that shoppers and customers use the chat feature on shipt.com or through the Shipt app for immediate needs and use email for non-immediate needs. Thank you for your flexibility, we'll share updates once available and apologies for the inconvenience.
Posted Sep 13, 2022 - 09:09 CDT