Shipt Phone Support
Incident Report for Shipt
Resolved
Functionality has been restored. We are no longer seeing degradation in call quality.
Posted Apr 22, 2024 - 12:05 CDT
Update
We continue to experience a loss of audio with phone calls coming into Shipt support. Please contact us via chat or email support from the help section of the app. We will update you as we work to restore our phone support.
Posted Apr 22, 2024 - 11:25 CDT
Investigating
We are currently experiencing a loss of audio with phone calls coming into Shipt support. Please contact us via chat or email support from the help section of the app. We will update you as we work to restore our phone support.
Posted Apr 22, 2024 - 10:31 CDT
This incident affected: Shipt Website.